Windows 7 USB Drivers



  • HashbangGamesHashbangGames Posts: 96Member
    Muffinsparticus, this is more or less exactly what I will be doing in this thread.

    But taking it a bit further, and doing step by step tutorials for how to get from point A ( examples ) to point B ( your own project implementation)

    going to take a couple of days, but i'll get them available asap.
    Marco Williams
    Hashbang Games

    Gravi is available on the OUYA look for it in the store!

    Steam Greenlight Vote yes on Gravi
    Purchase our Gravi on Desura
    Desura Digital Distribution
  • FatCatGameWorksFatCatGameWorks Posts: 13Member
    Just in case this helps anyone. I am using the default Samsung galaxy drivers. I simply selected to choose an already installed driver for the device and selected it from the options it gave. It gave a warning about it not being designed for the device, but it works perfectly.
  • BalbiBalbi Posts: 198Member
    Just in case this helps anyone. I am using the default Samsung galaxy drivers. I simply selected to choose an already installed driver for the device and selected it from the options it gave. It gave a warning about it not being designed for the device, but it works perfectly.
    This worked for me also when all other options failed. I chose to use the Samsung ADB Composite driver that I use with my Galaxy Nexus and it works like a charm now :)
    Lead Developer of Leroux
  • MooProductionsMooProductions Posts: 3Member
    I added the two lines to the inf file and reset ADB from Eclipse and it just works for me, though it doesn't list a name for the Ouya.  I can push apps to it and debug it.
  • VicariousEntVicariousEnt Posts: 63Member

    Aryik's post from the first page really helped, I was having the same problem most were navigating the labrinth of windows screens to get that magic combination...

    "Make sure you're choosing to select from a list manually and not using the search feature. It will then popup a dialog with a list of hardware types, and the top option is to show all, after that (before it's even done listing everything) all you have to do is press Have Disk and make sure you click on the INF file, not the folder. "

    When it says "Show All", click that and then press Next in the bottom right corner then Have Disk on the next screen and you should be gold (again, Win7 64bit).

  • AxonDigitalArtsAxonDigitalArts Posts: 3Member
    edited January 2013

    I realize it's been a good two weeks since your last post in this thread but thanks to your persistence and the detailed screenshots you put up, I was able to confirm that you and I were experiencing the exact same problem, and I have just cracked it thanks to an unfortunately vague but important post by pixjuegos.

    Your wisdom in suggesting to install the USB Composite Device driver was the nail in the coffin that resolved my problems. Thanks! However, it took me a bit to figure out how this would help me. I'll try to elaborate.

    For anyone with the same problem that Muffinsparticus and I ran into under Win7 64-bit and has already tried the instructions here:

    Follow these instructions, and I hope you'll have the same luck I did:
    1. Download the modified Google USB driver available from pixjuegos here.
    2. Open Device Manager
    3. Right click on Cardhu under Portable Devices and choose "Update Driver Software..."
    4. Click "Browse my computer for driver software"
    5. Click "Let me pick from a list"
    6. Select "USB Composite Device"
    7. Wait for the driver to install. After your PC gets this driver working, you should now be able to see a device with a yellow symbol indicating that it has no installed driver under the heading "Android Devices", a little bit like so (although mine is installed and working now):
    8. image
    9. Right click on the new Android Device and choose "Update Driver Software..."
    10. Click "Browse my computer for driver software"
    11. Click "Let me pick from a list"
    12. Click "Have Disk..."
    13. Browse to the pixjuegos' .inf driver file and click OK.
    14. Select "Android Composite ADB Interface" and click OK.
    15. Open up the ADT and confirm that your device is visible! I was able to create an empty project and simple test my device with a basic "Hello World!" apk to confirm that everything is good.
    Post edited by AxonDigitalArts on
  • plan-bplan-b Posts: 5Member
    @AxonDigitalArts i can still only find mine under universal serial bus controllers :/

    And its a USB composite device. Even though the Ouya is turned on it says it can't start.
    When i first plugged it in the computer recognized it as cardhu, but only once. Now it always tells me its a USB compositive device that isn't working. And I can't get further then .6 on your list because it says code 10 ( It can't start)
    *It also tells me when i go into "Have Disk" and when i select the .inf that it isn't compatible with 32 bit. Which I'm running.

    Any solutions?
  • AyrikAyrik Posts: 429Member
    Use 64-bit? Why are you running 32? It is Windows 7 right?
    Saga Heroes - Adventure RPG
    image image
  • AyrikAyrik Posts: 429Member
    Since the VID and PID have changed with the latest firmware, the android_winusb.inf needs to be modified. Change the previous OUYA lines to the following:

    %SingleAdbInterface%        = USB_Install, USB\VID_2836&PID_0010
    %CompositeAdbInterface%     = USB_Install, USB\VID_2836&PID_0010&MI_01
    Saga Heroes - Adventure RPG
    image image
  • HicsyHicsy Posts: 177Member
    nope. still nothing on 1.0.158.r1

     When mine was cardhu on my old pc it worked straight after installing the samsung galaxy toolkit drivers... now neither that OR the dodgey unsupplied hacked driver, nor the DIY is working on my new win7x64 install

     I have tried both ADB and ADB composite... also, it doesnt give the option to choose "USB composite device" in that other menu - not that i have ever had to do that previously
    Can't find aapt.exe? Temp fix: Copy another one from 'android_sdk/build-tools/17.0.0' back to your 'platform-tools'
    PM me        Facebook

  • AyrikAyrik Posts: 429Member

    Did you follow the official instructions here: Including the following:

    You will need to add the following line to ~/.android/adb_usb.ini for your OUYA console to be recognised;


    then run the following commands;

    adb kill-server
    adb devices

    Where, in Windows, ~/.android/adb_usb.ini is c:\users\{your name}\.android\adb_usb.ini

    Saga Heroes - Adventure RPG
    image image
  • MoggMogg usa.hawaii.oahu.mililaniPosts: 31Member
    Hey Hicsy,

    I fought with it for over 2 hours trying to get it to work after they changed this information... Following the previous instructions worked for me easily when it was Cardhu, but this second change just wouldn't work right away.

    I wish I had written notes to myself to help you more, but I tried making these changing and nothing worked. Eventually, I just unplugging the Ouya USB several times and let it redetect the device in Windows and that seemed to do the trick for me. Hopefully your situation turns out to be something similar.

    I wish they'd make some official drivers for this thing...
  • HicsyHicsy Posts: 177Member
    edited April 2013
    yep, thanks. Got it after about 2 hours of going in circles too.
     and yes, I had already added that .android/adb_usb.ini as per

     I did another uninstall (delete stored drivers),
     then install (have disk) -> choose my hacked .inf
     adb kill-server
     unplug, replug
     update driver (have disk) -> choose same set again
     then adb devices worked.

    For anyone else who struggles:
     * The ADB / Composite adb device selection didnt seem to make a difference so just follow official directions at
     * The pack from pixjuegos is now invalid... just modify your driver in sdk\extras\google\usb_driver\android_winusb.inf  as per official docs
     * as @Ayrik said, make sure you add the adb_usb.ini to your user profile, as per official docs
    Post edited by Hicsy on
    Can't find aapt.exe? Temp fix: Copy another one from 'android_sdk/build-tools/17.0.0' back to your 'platform-tools'
    PM me        Facebook

  • HicsyHicsy Posts: 177Member
    edited April 2013
    a quick tip from @tgraupmann in the unity category:
    tgraupmann said:

    android update adb

    creates that file in your .android folder.

    The android app can be launched from the Android SDK tools folder.

    so basically you navigate to your android sdk / tools    (mine is c:\Android\sdk\tools)
    shift+right-click -> "open new command window here"
    and run his command: 
    android update adb

     In theory, following the steps in the docs 
     (ie:  echo 0x2836 >> "%USERPROFILE%\.android\adb_usb.ini"  )
    should at least make the file, but Tim's is probably a better starter for anyone with a fresh OS like mine was

    see the thread here:

    edit: trying to get the link to parse (weird forum bug?)
    Post edited by Hicsy on
    Can't find aapt.exe? Temp fix: Copy another one from 'android_sdk/build-tools/17.0.0' back to your 'platform-tools'
    PM me        Facebook

  • maxdbmaxdb Posts: 10Member
    Hey guys,

    I can't get my apk to build and run on to the OUYA. I use the button on the 'Build settings' box and then it says it can not detect any android device I have followed some of the instructions which Ayrik and Hicsy had suggested but it wont let me build and run to the ouya. Also it is plugged in and all that lol.

    I can go on to the computer and look through the files on the OUYA but no build and run.

    Any help would awesome

  • HicsyHicsy Posts: 177Member
    @maxdb and anyone else who is still stuck:
     - check your device manager shows something like "Android Device" -> "ADB Interface"
     - check the %USERPROFILE%\.android\adb_usb.ini file has the right identifier on a new line (currently 0x2836)
     - make sure you're calling "adb" commands from your Android\sdk\platform-tools directory
     - "adb kill-server"
     - DO NOT use the old hacked drivers from pixjuegos, modify the one in android sdk yourself
     - make sure you DO have USBdebugging enabled on the console:
     - "adb devices"

    "Developer Options"
    "USB Debugging"

    If you found out it was something else other than listed here, be sure to share your solution
    Can't find aapt.exe? Temp fix: Copy another one from 'android_sdk/build-tools/17.0.0' back to your 'platform-tools'
    PM me        Facebook

  • david_bennettdavid_bennett Posts: 9Member
    After upgrading to the 1.0.3 SDK, I found that I had to modify the lines in the android_winusb.inf file again:

    %SingleAdbInterface%        = USB_Install, USB\VID_2836&PID_0010&REV_0232&MI_01
    %CompositeAdbInterface%     = USB_Install, USB\VID_2836&PID_0010&MI_01

    If that doesn't work for you, paste these lines under both sections [Google.NTx86] and [Google.NTamd64].

  • PeasantDavePeasantDave Posts: 17Member
    edited May 2013
    Edit: Started working. Not sure why it didn't the first time.
    Post edited by PeasantDave on
    Ouya game postponed... but I did release a tabletop RPG!
  • Voporak5Voporak5 Posts: 73Member
    I'm getting the same problem, failed to install the driver. I can access the files on my OUYA in My Computer but Unity doesn't recognize the console at all.
  • Voporak5Voporak5 Posts: 73Member
    Ok I fixed mine, i had to add wat david said and also organize my pathing a bit throwing the java folder, android sdk, and ndk all into one folder
  • HardycoreHardycore Toronto, Ontario, CanadaPosts: 17Member
    Thank god for this thread!  I was pulling my hair out, but after trying a few combinations of things suggested on here I got it showing up in the device list!!!

    For me, I ended up trying reinstalling my galaxy s2 drivers, found here
    then uninstalled the ouya, unpluged, repluged, it came up looking slightly different in device manager.
    In device manager before it was listed as "Android ADB Device"   now its listed as
    Android Composite ADB Interface.

    Thanks again everyone!!! :D
    Love Retro Gaming?!
    Check out our new release World Destroyers!

  • baconneckgamesbaconneckgames Posts: 1Member
    If anyone else if having problem with this as I was, there is a really good write up on this dude's blog that covers the entire process of getting a game on your ouya, specific to this conversation is the 3rd part, "Set up your PC or Mac to talk to your Ouya":

    He breaks it down step by step for everything you need from start to finish, and it fixed my issue (for win 7 64bit machine drivers). There is a lot of other stuff you have to do too, so it's all in all a pretty good read, very clear and precise instructions.
Sign In or Register to comment.